0

Warning:java: source value 1.5 is obsolete and will be removed in a future release hatası çözümü

Merhaba arkadaşlar  bu yazımda intellij idea ile java kodu yazanların karşılaştığı bir hatadan bahsetmek istiyorum. Evet yazının başlığından da anlaşılacağı gibi eğer projenizde maven desteği varsa böyle bir hata alma ihtimaliniz var. Project structure kısmında farklı bir versiyon gözükmesine rağmen bir türlü bu hatadan kurtulamıyorsanız o halde “pom.xml ” dosayınızı açın ve yukarıdaki kodları yapıştırın yada çalıştığınız java versiyonuna göre uyarlayıp yapıştırın. 

<build>
    <plugins>
        <plugin>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

admin

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir